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Stochastic Optimization

* Simulation is great, but can we do better?

* Introduction to optimization
— Applications
— Crystal Ball decision variables
— Deterministic vs. Stochastic
* Using OptQuest
— How 1t works

— OptQuest menus, toolbars, and basic terminology
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Stochastic Optimization

* Simulation models by themselves can only give you a range of possible
outcomes for any situation. They don't tell you how to control the situation
to achieve the best outcome.

* Stochastic Optimization is a combination of simulation and optimization,
which lets you make the best (optimal) decisions while accounting for the
variability or uncertainty inherent within a process.

* OptQuest enhances Crystal Ball by automatically searching for and finding
optimal solutions to simulation models.

OptQuest Results ot
) Que .
Edit View Analyze Preferences Help 0 pt J-UESt RE'SU":S
203 Total Solutions Solution Analysis View 10 Displayed Edit View Analyze Preferences Help
Objective — Requiremenis — Constrainis &
- Maximize Mean | 5% Percentie >000 203 Simulations Best Solution View
Rank Solution # Gross Proit C: 4*Bratwurst + alian Sausage <= 12520 | 2 5°Summer Sausage + Bralwurst+ 3't_| Summer Sausage +1
1 203 $11541.72 874 10804 <« 12520 13878 - 14,100 6480 Performance Chart
2 202 1153995 8565 10.800 < 12520 13,880 = 14,100 5480
3 201 115318 8755 1079 < 12520 13,881 = 14,100 5480 $15,000.00
4 200 5115341 8945 10792 12520 13883 - 14100 5480
5 139 §1153464 9135 10788 < 12520 13884 - 14100 5480 $12,000.00
6 138 §1153287 9325 10784 12520 13,886 u 14,100 sa0) c
7 197 $11531.10 95.15 10.780 12520 13887 - 14,100 6480 2 . Feasible salution
8 196 1152933 57.05 10,776 = 12520 13,889 = 14,100 6.480 = ‘””’ i :
bl : < : i < - - v = 35,000.00 @ Infeasible solution
< | b3 e
Sratistics E - - == Bestfeasible solutions
Miimum S15578 8374 10.768 12520 13878 14,100 6480 B 000 R B echinieasibl e =al tinis
Mean $153875 230 0.7 12520 13.885 14,100 5480 8
i Last bestsolution
Maximum S1154172 10086 10804 12520 13,892 14,100 5430 O 53,000.00 *
Std. Dev. 5536 576 12 0 5 [] []
Showthe best ndlude
O 73] solutons [ Eeasile soluions (194) $0.00 -
@ 4 of solutions [] Infeasible solutions (3)
O Al feasible solutions (134) a 4 8 B‘;. 1Iut4 125 148 167 188
imulations
O New best solutions (178)
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Optimization Applications

Business Question

Optimization’s Answer

What level of demand are likely for next month?

Find the order points that maximize revenue.

What will production rates be for a new oilfield
under consideration?

Determine number of wells to drill to maximize
net present value.

Which stock portfolio should | pick?

Choose investments that have the highest return
for given risk levels.

How should we manage our distribution
operations?

Determine set of locations that minimize costs
while meeting service requirements.
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Crystal Ball Decision Variables

We previously used Crystal Ball Assumptions and Forecasts in the our models

With optimization, we also use Crystal Ball Decision variables
— These are controllable inputs (X’s)

— Values that are not certain, but are within your control

Define Decision Yariable: Cell H6

Examples: Amount of product to produce,

MName: |S|.|mmer Sausage E gf
amount of money to invest in each asset Bounds
class Lower 0w Upper

Type

) Continuous

CY R
() Binary (Yes-No)
() Category (Nominal)

) Custom; | E

(Example: 100, 200, 400)

[ 0K | [ Cancel | [ Help |
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What is Optimization?

—Find the input values (Decision Variables) that make
the output (Forecast Statistic) as large or as small as

possible.
Decision Calculations
Variable(s) —>  including —> Forecast(s)

Assumptions

X — —— F(X)=Y

An optimization model answers the question "What's best?" rather
than "What happened?" (statistics), "What if?" (simulation) or
"What will happen?" (forecasting).
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Deterministic vs. Stochastic Optimization

* Deterministic (e.g. MS Excel Solver)
— Determines input values that place the output at its optimum.
— Does not account for uncertainty in inputs or the range of possible outcomes.
— Results in optimal single-point estimate of the output.

* Stochastic
— Option to add statistical requirements on outputs.

* Example: Maximize mean of return on investment (output) with a
requirement that the standard deviation is less than a certain value.

— Allows for real-world variation to be accounted for while optimizing the
design.

— Results in optimal design where the output is within acceptable variation limits.
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How OptQuest Works

Set Decision Variable Values (within Constraints)

1

Run the Simulation

l

Evaluate the Objective Function Value (Is this the Best solution?)

!

Evaluate any Requirements (Is this solution feasible?)

v

Repeat until all solutions have
been tried or maximum time
reached
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Example: Ray’s Red Hots

* Produce 5 types of sausage:

— Summer sausage, Bratwurst, Italian Sausage, Pepperoni, Polish
Sausage

* 4 ingredients:
— Veal, Pork, Beef, Casing

e Must decide how much of each type of sausage to produce subject to
ingredient constraints

*  Your goal: maximize profits while ensuring less than 5% chance of
running out of casing.
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Example: Ray’s Red Hots

* Run the simulation in Crystal Ball to understand the performance of
the model without optimization.

* What are some key insights prior to performing optimization?

Forecast: Gross Profit

Edit View Forecast Preferences Help

5,000 Trals Split View 4 574 Dhsplayed
Sensitivity: Gross Profit
Gross Profit Statistic | Forecastvalues Edit View Sensitivity Preferences Help
Trials 5,000 5,000 Trials Contribution to Variance View
041 Mean SR 16279 Sensitivity: Gross Profit
' Median 28,167.55 0.0% 10.0% 200% 300%
010 - Mode - ltalian Sausage unit profit
| Standard Deviation 5255 80 .
0.09 k Summer Sausage unit profit
\ariance 86543212
008 - Shewness 0.0539 Pepperoni unit profit
__':3:.'1 0.07 - :Il'l Kurtosis 289 Polish Sausage unit profi 13.0%
5 o & |Coeff. of Variability 0.0313 Bratwurstunitprort | |
a @ |Minimum §7.295.73 _
=) = - Casing - bratwurst -0.1%
i 0.05 - Q Maximum 59,062 45
Mean Std. Errar 3162 Casing - summer sausage 0.0
0.04 ) ) : :
Casing - Italian sausage 0.0%
0.03 - Casing - pepperoni 0.0%
0.02 - Mean = $8,163.73 - Casing - Polish sausage 0.0%
0.01
0.00

5760000  S8,000.00 5640000  58300.00

| J56.250.00) Certainty: [37.95 % | [infiniy Tianyang Wang FIN 670
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Example: Ray’s Red Hots

 Add decision variables to the model for the
quantity to produce for all 5 products

— Use cell referencing for the name

Mame: |Summer Sausage E g,'

Bounds

Type
() Continucus

CH
() Binary (Yes-Ng)
(O Category (Nominal)

O Custom: | E

(Example: 100, 200, 400)

[ ok | | Cemesl | [ Help |
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Launch OptQuest

e Select Run > OptQuest, or click on the OptQuest
button on the ribbon.

e Review the Welcome screen, then click Next, or

use the navigation panel to select Objectives

! OptQuest |:.@

Welcome to OptQuest for Crystal Ball

Objectives
. . Decision Variables . . . . . .
NaV|gat|On PanEI OptQuest searches for and finds optimal solutions to your simulation models. By themselves, simulation
Constraints models can only give a range of possible outcomes for any situation. With OptQuest, you can determine
Out the best combination of decision variables that yields the results you are seeking.
pticns

First, select a forecast statistic as the objective that you wish to maximize or minimize and specify any
requirements on other statistics.

Next, selectwhich decision variables you're
interested in analyzing and specify any constraints
on their values.

Finally, choose your options and run the optimization.

(Mote: all of your optimization settings will be stored
in yourworkbook automatically when you choose Run.)

< Back Nest > fon [ Gese  J[ Wb ]
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Colorado State University

Detine Objective

| Cbjectives: |@

Maximize the Mean of Gross Profit

> Maximize

Minimize

E SetTarget

The 5% FPercentile of Casing Remair

‘welcome

| Objectives
Decision Variables
Caonstraints

Cptions

Select an objecfive and optionally spec

. |Dbjecti1.res: (7)

Maximize the Mean of Gross Profit

yd

I"-'Iaxlmlze the Mean of Gross F'roft

| Reguirements: l@ \

>|Me_aﬂ|%

Median
Reguirements: Mode

The 5% Pel xoPercentile
Mirirnurm

Maximum

Standard Deviation

The 5% Percentile of Casing Bemaining

Because OptQuest
performs stochastic
optimization (i.e.
running simulations)
you can choose
among many statistics
to optimize.

3. |Dbjecti1.res: l@

Maximize the Mean of Gross Profit

Reguirements: (@)

Veal Remaining
Pork Remaining

Beef Remaining
The 5% Percentile of | (Casing Remaining

=

> Gross Profit h

Tianyang Wang

FIN 670



Define Requirements

* A model may or may not have requirements

* Requirements limit which solutions are acceptable,
based on the simulation results

» Example: 95% certainty that Casing 1s available -
expressed as 5™ percentile of the forecast ‘Casing

Remaining’ has lower bound 0.

Welcome / - - ; \
elect an objective and optionally specify requirements >

Objectives .

Decizion Varizbles \ PW
Constraints |Objec:ti1.'es: @
Options Maximize the Mean of Gross Profit

Reguirements: l@

The 5% Percentile of Cazsing Remsining mustbe gresterthan 0.00
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Select Decision Variables

» Review/Update Decision Variables imported from
spreadsheet

* Freeze decision variables that should not be
considered (optional)

' OptQuest
welcome X . X )
Review decision variables and change properties as necessary @
COhjectives
| Decision Variables | [] Show cell locations
Constraints Decizsion Varables Lower Bound Base Caze Upper Bound Type Step | Freeze
) Bratwurst 0 1.000 5.000 Discrete 1 ]
Options
ftalian Sausage 0 1.000 5,000 Discrete 1 ]
Pepperoni 0 1,000 5000 Discrete 1 ]
Polish Sausage 0 1.000 5.000 Discrete 1 ]
Summer Sausage 1] 1,000 5,000 Discrete 1 [
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Detine Constraints

! OptQuest

* A model may or may not

\Welcome . . . . .
Objecives Optionally, specify constraints on the decision variables @ h ave con Str ai nt S
Decision Variables
| Constraints Al| [ constraints @ Type  Exclude | . .
Options 1 4 Bratwurst + ltalian Sausage <= 125620 Linear 1 ¢ ConStraI ntS reStrI Ct

2 25"Summer Sausage + Bratwurst + 3"talian Sausage + 4"Pepperoni + Polish Sausage <= 14100 Linear O d eCIS I O n Va rl a b I e

3 |S|.|mn'|er Sausage + 1.5%alian Sausage + 3 Polish Sausage <= 6480 Linear [Fl re I atl O n S h I pS

> O

« Constraints may be linear
or non-linear
’ Insert Wariable. .. ] [ Insert Reference... ] [ Add Comment... ] [ Efficient Frontier ] [ Delete ]
[ <Bock J[ MNex> | [ Bn J[ Coe J[ Hb |

Use these functions to help quickly build and document your constraint
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Select Options

e Choose the number of simulations or time

duration to run the optimization, then click

Crystal Ball run
preferences (# of

trials, run speed, etc),
may be viewed and
edited prior to
beginning the
optimization.

! OptQuest |_
WWelcome ) L
Choose your options and run the optimization @
Objectives
Decision Variables '
. COptimization contral Type of optimization
Constraints
- 1| ) Run for simulations (%) \nifith simulation (stochastic)
(%) Run for minutes ) Wwithout simulation (deterministic)
Simulation: l Run Preferences...
‘While running Decision varable cells

(") Show chart windows as defined
(%) Show only target forecast windows

Update only for new best solutions

() Leave set to original values

(®) Mutomatically set to best solution

[ Advanced Options . ]

[ Bn [ Gose ]|

Hep |
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While the Optimization 1s Running

— Solution Analysis view (View > Solution Analysis)

— View objective function, requirement, constraint, and decision variable information
for solutions found during the optimization.

Use filters to control which solutions are displayed

) OptQuest Results

Edit View Analyze Preferences Help
f 28 Total Solutions Solution Analysis View 15 Displayed
Objective — Requiremenis — Constrains
|  Maximize Mean 5% Percentile > 0.00
Rank Solution # Gross Proft Casing Remaining 4*Bratwurst + ltalian Sausag
3 24 $10,665.28 804 61 6,368 <=
< 4 25 $10,669.13 800.85 6372 <=
3 26 31067297 795709 6.376 <=
2 27 510,676.82 793.33 6.380 <=
1 28 $10,680.67 785.57 6.384 <= LJ
\. < | >
Statistics:
Minimum 510,628.1 < 78957 LT
Mean 510,653.83 815.82 6.356
Maximum 510,680.67 841.10 6,384
Std. Dev. §$17.05 16.69 18
Show the best Include
@® solutions Eeasible solutions (26)
O 7| =ofsolutions Infeasible solutions (2)
O Al solutions (28)
(O New best solutions (25)
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While the Optimization 1s Running

— Best Solution View (View > Best
Solution)

OptQuest Results

Edit W¥iew Analyze Preferences Help
142 Simulations Best Solution View

— Performance chart plots the values of s

05;512000.00 ,_.ﬁ———i» @ Feasiblesolution
000.00 j’ -

each simulation result (select : e T[S

@ «+Bestinfeasible solutions
g $3,000.00 4 Lastbestsolution

Preferences > Show All Solutions to || = =
filter visible solutions)

-
Best Solution: Simulation # 142
Objeclives Value
Mazximize the Mean of Gross Profit 51142371
—| Requirements Value
The 5% Percentile of Casing Remaining must be greater than 0.00 183.56

— Constraints Left Side Right Side

— Information about the current best
solution 1s disp]ayed at the bottom < e I EET

Summer Sausage + 1.5%alian Sausage + 3°Polish Sausage <= 6480 6,480 | <= 6,480

— Decision Variables Value

Bratwurst 2,640
ltalian Sausage [1]
Pepperoni 4
Folish Sausage 961 L
Summer Sausage 3,597
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Colorado State University

While the Optimization 1s Running

* Forecast charts of the current best solution may be

OptQuest Results

! Forecast: Casing Remaining

viewed during and after the optimization run.

[ B

=JE3

SE DED fEfe Edemes FEE Edit View Forecast Preferences
309 Simulations Best Solution View
Performance Chart Frequency View 4987 Displayed
ST Casing Remaining

& 1
2 511,660.00
= = Bestsolutions
E $11,660.00 =+ Infeasible soluons

[ T # Lastbest solution TE ) Forecast: Gross Profit
< 511,63000 . Edit View Forecast Preferences Help

R e e % 5,000 Trials Freguency View 4 584 Displayed
Simulations o 002
= Gross Profit
o
Best Solution: Simulation # 72
Objectives Value 0.01 - Mean = 484 64

Maximize the Mean of Gross Profit $1167145

— Reguirement: Val ! ! !

= = 40000 60000  00.00
The 5% Percentile of Casing Remaining must be greater than 0.00 279 ?:\ 0.06 -
b comm [0 = 4] | 3

- Constraints Left Side Right Side 9 0.05 -
4 Bratwurst + halian Seusage <= 12520 12,520 | <= 12520 0 0.04-
2.5*Summer Sausage + Bratwurst + 3"ltalian Sausage + 4*Pepperoni + ... 14,100 | <= 14,100
Summer Sausage + 1.5%alian Sausage + 3°Polish Sausage <= 6480 6,026 | <= 6.480 i

0.02 - Mean = £11.671.45

= Decision Variables Value 0.01 -
Bratwurst 3130 '
ltalian Sausage 0. T 1 1 1

$10,000.00 $11,000.00 $12,000.00 $13,000.00

Pepperon dollars
Palish Sausage 630
i b Corsine: (0000 % 4
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Optimization Results

— Use the Edit menu to copy any solution’s decision variable values to

the spreadsheet

Copy Solution to Spreadsheet Solution]
Objecive +
. imize Mean | &
age Setup... ross Prolt
Er?n:Preview... $11676.91
. $11.676.71
1443 $11,676.56
— Use the View menu to see the Best Solution or compare multiple
solutions (Solution Analysis) . OptQuest Results

Wiew
xm
r v Solution Analysis

]

— Use the Analyze menu to create a report or extract your OptQuest
I‘GSUI’[S ' OptQuest Results

Edit View WNEVEEN Preferences He

|E' Create Report...
E Ewtract Data...
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Optimization results

— Gross Profit improved from $8,169 to $11,682, while meeting the
requirement for casing remaining.

Improved Gross Profit Casing requirement satisfied

(=1

! Forecast: Casing Remaining

EEX

! Forecast: Gross Profit
Edit View Forecast Preferences Help Edit View Forecast Preferences Help
5,000 Trials Frequency View 4 983 Displayed 5,000 Trials Frequency View 4,985 Displayed
Gross Profit Casing Remaining
0.03 400
210
0.07 960 0.04
180
0.06 300
0.03 150
£ 005- 250 1 = )
= o = 3
O O =
B 004 200 E 120 2
5 0.03 150 E_ = e =
0 0.03 - & a0 \Q
0.02 4 IMezn = $11.682.09 100 &0
0.01 Mean = 440.26
0.01 50
30
ﬂ' 1l 1 1 1 1l 1l G
510,200.00 $10,800.00 $11,400.00 $12,000.00 512,600.00 5$13,200.00 0.00 1 0 1 o
dollars -200. . L L
Cori: [0 | b Coraine 500 |%

Tianyang Wang
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Compare results

w/o Optimization with Optimization
Mean Gross Profit $8,169 $11,682 f43%
% short casing 0% ~5%
Summer Sausage 1,000 3,714
Bratwurst 1,000 3,130
ltalian Sausage 1,000 0
Pepperoni 1,000 23
Polish Sausage 1,000 922
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Summary

Simulation answers ‘“What 1f?”” while Optimization answers “What’s best?”

Optimization is used across many industries, including management,

manufacturing, finance, and engineering.

Stochastic optimization offers more robust solutions compared to

deterministic optimization.

OptQuest 1s a powerful tool for stochastic optimization that works hand-in-
hand with your Crystal Ball models.
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