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Background 
These methods were developed to be a relatively low-cost, repeatable technique to monitor fine-scale 

spatial patterns of forest cover. While this publication is the result of work with the Front Range 

Collaborative Forest Restoration project (FR-CFLRP) in Colorado, these methods are applicable to 

other restoration projects with similar forest spatial pattern concerns.  

The FR-CFLRP has broadly defined the desire to increase spatial heterogeneity in forest stands, including 

increases in tree clumps and the number of openings >.25 acres in size (Clement and Brown 2011).  

Therefore, monitoring that quantifies tree spatial pattern is necessary to ensure post-treatment forest 

condition goals are met.  The current FR-CFLRP monitoring plan calls for the collection of plot-based 

measures of tree density and size in each treatment unit, or stand.  This data can provide the mean and 

among-plot range and variance of tree density and size values, but does not provide any spatial 

information.  Traditional methods of quantifying spatial pattern require labor-intensive stem mapping and 

other demanding measurements that are not feasible given labor and budgetary constraints.  The 

protocol outlined here allows quantification of forest canopy cover spatial distribution that, in 

conjunction with traditional forest inventory, presents more complete picture of forest structure for 

monitoring of restoration goals than forest inventory data alone.  

The method described in this document uses National Aerial Imagery Program (NAIP) imagery to 

quantify spatial pattern of forest cover. This publically-available imagery is collected every four years and 

includes four bands: the three visible bands of light (red, green and blue) and a near-infrared (near-IR) 

band.  Near-infrared wavelengths of light are strongly reflected by vegetation, and the near-IR band is 

very useful in remote sensing of forests (Campbell and Wynne 2011). We use the ENVI software 

package (Exelis Visual Information Solutions) to delineate areas of coniferous canopy, shadow, 

herbaceous ground cover and bare soil (e.g. unpaved roads) from the imagery.  The reflected 

wavelengths of these cover types are relatively unique and allow for the mapping of forest cover.  

After mapping, the spatial distribution of forest canopy patches (groups of trees with continuous 

canopy) in a matrix of bare-ground and herbaceous groundcover (gaps between trees) can be quantified 

using FRAGSTATS (McGarigal et al. 2012), a program developed to analyze spatial patterns of landscape. 

Metrics such as the percent cover, largest patch index, edge density, patch size, patch density, patch 

perimeter-to-area ratio, and Euclidean nearest-neighbor distance can quantify forest cover patterns to 

make comparisons among different forests and monitor treatment effects through time. We encourage 

you to alter these methods to best suit your monitoring needs. For example, one could perform the 

same analysis with a focus on openings rather than forest to better understand treatment effects on 

meadow size and frequency.  
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Protocol Overview 
The following analysis technique has three main steps:  

1) Processing aerial images with ENVI;  

2) Extracting zones of analysis from the larger photos with ArcGIS; and, 

3) Analyzing spatial patterns with FRAGSTATS.  

The image processing is the most time-consuming part of the process. We recommend reading through 

the entire protocol to get an overview of all the steps before beginning analysis. 

Please note that these instructions are written for ENVI 5.0, ArcGIS 10, and FRAGSTATS 4.1; and exact 

procedures will likely differ among software versions. ENVI (www.exelisvis.com/ProductsServices/ 

ENVIPlatform.aspx) and ArcGIS (www.esri.com/software/arcgis) are available for purchase. FRAGSTATS 

(www.umass.edu/landeco/research/FRAGSTATS/FRAGSTATS.html) can be downloaded free of charge.  

While we use ENVI, many other software packages capable of image analysis are available and may be 

used instead, including freeware such as Multispec (https://engineering.purdue.edu/~biehl/MultiSpec/).  
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Processing aerial imagery with ENVI 
The goal of aerial imagery processing is to accurately map forest canopy in treatment areas. To 

categorize images, we must first define regions of interest (ROI) that represent categories of vegetation 

cover. ENVI then classifies each pixel in the photo based on the spectral signatures using one of several 

algorithms available in the software. An independent set of regions of interest is then used to check 

classification accuracy. We used National Aerial Imagery Program (NAIP) 4-band (red, green, blue, and 

near-infrared) imagery with a 1 meter resolution.  

The steps below will walk you through this process. 

Pre-classification processing of imagery 

The first step is to re-size the image resolution to 2.4 m from the original 1 m pixel-size. This re-

sampling is intended to reduce the influence of shadow on our analysis. Meddens et al. (2011) found a 

2.4 m resolution was optimal to minimize within-canopy shadows and maximize classification accuracy.  

(Influence of shadows can be further minimized by classifying them as part of the “background” in 

FRAGSTATS [see further discussion later in this document].) 

The first step is to open ENVI. Open the image file (.sid or .jpg are supported) by going to File > Open. 

Then open the treatment boundary shapefile. Go to File > Data Manager. Click the folder with an arrow 

in the left-upper corner of the dialog box. Browse to the file. (Click on an Adobe Illustrator file if 

present.) 
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Go to Toolbox > Raster Management > Resize Data and select the image to resize. (Leave the spectral 

and spatial subsets at default [full scene and spectrum]). In the “Resize Data Parameters” dialog box, 

choose ‘Set output dims by pixel size’ and set output X pixel size to 2.4 and output Y pixel size to 2.4. 

Choose ‘Pixel aggregate’ for resampling type. Choose output file name and location, and click ‘OK’.  

The re-sizing process will take some time. A dialog box will appear that should look like this: 

 

Once the re-sizing is complete, the new layer with the resized data will automatically be added. Double 

check that the new resolution is correct. (The file size should decrease substantially if it completed 

successfully.) 

Then next step is to add in a derived Simple Ratio (SR) band. When developing these methods, we 

investigated the improvement in classification accuracy from adding three derived bands commonly used 

in remote sensing analysis of vegetation: the Normalized Difference Vegetation Index (NDVI, the 

normalized difference between the near-infrared and red bands), the Simple Ratio (SR, the ratio of the 

near-infrared to red band) and the Red Green Index (RGI, the ratio of the red band to green band). 

While all three improved classification accuracy somewhat, the addition of the SR band to the red, 

green, blue and near-infrared bands produced the most accurate results for image classification into 

coniferous canopy, shadow, herbaceous ground cover and bare soil cover types. 

To create the SR band, go to Toolbox > Band Ratio > Band Math. Create a new expression or recall a 

previously saved expression. To create a new expression, simply type ‘float(B4)/float(B1)’ in the box, and 

click ‘Add to List’.  This expression tells the program to calculate the ratio of the B4 band (the near-

infrared band) to the B1 band (the visible red band). Then click ‘OK’. (See following image.) 
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(You can save this to an .exp file for use later by clicking ‘Save’.  You will then be asked to select an 

output directory and a file name.  To reload an existing .exp file, click ‘Restore’, select the file, and click 

‘Open’. If you have used an expression previously during the ENVI session, it will appear in the ‘Previous 

Band Math Expressions’ box.  In this case, you can simply click on the expression you wish to use and it 

should appear in the ‘Enter an expression’ box.) 

After entering the expression, you will be asked to identify which bands are B1 and B4 in the ‘Variables 

to Bands Pairings’ dialog box. Simply select ‘B1-[undefined]’ in the ‘Variables used in the expression’ box 

and then click on ‘Band 1’ in the ‘Available Bands’ box.  (Band 1 should be the visible red band. If your 

bands happen to be labeled differently, make sure to choose the red band.) Repeat for B4, which should 

be linked to Band 4 (and should be the near-infrared band). The window should now look like that in 

the following image. 
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Now, select a spatial subset for the band calculation (use Full Scene to calculate the SR band for every 

pixel), output the result to a file, and enter a filename for the resulting SR band. Click ‘OK’. 

Next, merge the SR band with bands 1-4 (all should be at the 2.4 m resolution). Go to Toolbox > 

Raster Management > Layer Stacking. Select the two files to merge. In the options, leave the defaults as 

they are (inclusive, UTM, Zone 13, NAD83). Choose the name and location for the 5-band file and click 

‘OK’. 

Defining Regions of Interest (ROIs)  

To classify the image into different cover categories (e.g., canopy, shadow, herbaceous cover, and bare 

ground/roads) you must first define areas that represent these categories in the image. The spectral 

signatures from your delineated ‘Regions of Interest’ (ROIs) are then applied to the whole image to 

classify each pixel as one of the categories.  

First, a vector layer must be created for each of the cover classification categories. To create the vector 

layer, go to File > New > Vector Layer (see following image). 
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A dialog box will pop up. Change the layer name to reflect the category for which you are going to 

define the ROIs. For example, ‘Canopy’. Leave the record type as ‘Polygon’. Select the 2.4 m resolution 

image with 5 bands as the source layer. (Sometimes the layers do not show up in the dialog box list. If 

there are empty spaces in the list, click in this area and see if the layers appear.) 

 

To create your ROIs, you will draw polygons around areas that represent the category you are trying to 

define. For canopy ROIs, you will draw polygons around areas you know are canopy. You should draw 

polygons that represent the full range of the category you are trying to represent. The polygons should 

be spread around the image and not concentrated in one area. You can toggle between the original (1 

m) and resampled (2.4 m) resolution image when creating your ROIs to get a clearer view of the ground 
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cover. However, the classification will only use the pixels in the 2.4 m resolution image. You should have 

25 or more ROI polygons for each category.  

To draw polygons, select the ‘Vector Create’ tool at the top of the toolbar. It looks like this:  

(You can also hover over the icons to see what they are called. Other useful tools are the ‘Vector Edit’, 

‘Vertex Edit’, and ‘Undo’ tools.)  

Before creating vectors, make sure you are editing the correct layer. Right-click the layer and choose 

‘Set as active layer’. After doing this, there should be a red box around the layer icon. 

To create a polygon, click around the shape you want to create. To complete the polygon, double click 

on the first vertex that was created to create a closed loop. If your polygon is not correct, you can 

delete it by pushing the ‘Back’ tool at the top of the screen. You can also make the deleted polygon 

reappear by pressing the ‘Forward’ button. 

When you are done creating your polygons, right-click on the layer you have been editing and select 

‘Save As’ from the menu. Be sure to navigate to the appropriate location to save the file. 

 

Repeat this step for all cover classifications of interest (i.e., canopy, shadow, herbaceous cover, and bare 

ground/roads).  

Once you are done drawing your polygons for all categories, you will convert these vectors to ROIs. 

Each category’s vector file needs to be converted to a ROI separately. For each vector file, go to 

Toolbox > Vector > Convert Vector to ROI. Select the vector file of interest (one only) then click ‘OK’. 

In the next dialog box, choose ‘All records to a single ROI’. Click ‘OK’.  
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In the next box, choose the base layer. It should be the 5-band resized image with a 2.4 m resolution 

(not the original 1 m resolution). The ROI file will now be added to the Layer Manager list.  

Repeat these steps for all categories. Then, right-click the Regions of Interest file and save it as a .roi file 

(see next image). This file includes the information for all categories and will be your ‘Classification ROI’ 

file. 

You may want to merge ROI files at some point. To do this, go to the ROI Tool dialog box menu bar, 

select Options > Merge Regions. The Merge ROIs dialog appears with two lists of all defined regions. 

Under Choose Base ROI to Merge, select the name of a region. Under the ‘Choose ROIs to Merge’ list, 

select the names of the regions to merge into the base region. Click the ‘Delete Merged ROIs?’ toggle 

button to select whether or not to delete the individual regions being merged. Then click ‘OK’.  

 

Calculating separability in ENVI Classic 

Separability is a measure of differences between the spectral signatures of each cover class’s ROIs. High 

separability is desirable to reduce misclassification of image pixels. A value of 2.0 indicates perfect 

separation between the spectral signature of the user-defined classes.  

To calculate separability, open ENVI Classic from inside the ‘Tools’ folder of ENVI 5.0 on the Start 

menu. (See following image.) 
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When you’ve opened ENVI Classic, a Toolbar will open at the top of the window. Open the 5-band, 2.4 

m resolution image file using this top toolbar by going to File > Open Image File. A dialog box titled 

‘Available band list’ will pop up. Select the ‘RGB’ toggle at the bottom then select the first three bands 

for R, G, and B by double-clicking them. Click ‘Load RGB’ and the image should load in three windows 

zoomed to different resolutions. 

In the main window toolbar (not top toolbar), go to Tools > Region of Interest > Compute ROI 

Separability. Click the ‘Open’ button on the screen, browse to your classification ROI file, and click 

‘OK’. (See following image.) 
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Back in the ‘Select Input File for ROI separability’ window, select (and highlight) the input file. Click ‘OK’. 

A dialog box that looks like the following image should appear: 
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Select all categories by highlighting them or by pressing the ‘Select all regions’ button. Then press ‘OK’. 

A table will appear titled ‘ROI Separability Report’. Save the report for future reference. If you achieve a 

separability value of 1.8 or greater, you can now proceed to image classification. Separability values less 

than 1.8 indicate that the ROIs you selected are not clearly defined.  If your separability value is lower 

than 1.8, we recommend you revise your ROIs (by redrawing and/or increasing the number of polygons) 

to ensure that your classes are distinct. 

Classification of imagery  

ENVI uses an algorithm to define land cover categories across the entire image based on the spectral 

signature from pixels defined in the ROIs. This type of classification, based on user-defined ROIs, is 

called supervised classification. Supervised classification can be done using several different algorithms, 

including the Parallelepiped, Minimum Distance, Mahalanobis Distance, and Maximum Likelihood 

algorithms (Richards 1999). We tested these four algorithms and found that the Mahalanobis Distance 

algorithm resulted in the best classification accuracy classification with our dataset, and was therefore 

used in all subsequent analyses. We recommend you test the various algorithms to find that which 

produces the best classification accuracy for your analysis area(s). 

To begin, open your 5-band, 2.4 m resolution image and the classification ROIs in ENVI 5.0. Go to 

Toolbox > Classification > Supervised Classification > Mahalanobis distance classification. Then select 

your input file. It should be the 2.4 m resolution file with 5 bands.  Press ‘OK’. (See following image.) 

  

Another dialog box will appear. In the ‘Select classes from regions’ window, highlight all classification 

categories (e.g., roads, bare ground, canopy, shadow). Select ‘None’ for ‘Set Max Distance Error’. Do 

not change the rule images options. Select where you want to save your file by clicking the ‘Choose’ 
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button and navigating to the appropriate location. (The dialog box should look like the following 

picture.) Then click ‘OK’.  

  

The classification will begin and may take several minutes to finish.  

Once the process is complete, the classified image will appear (see following image). Toggle between the 

classified image and the original NAIP image to visually check for accuracy. As you do this, focus on 

areas that you actually wish to analyze rather than areas in your image that may be irrelevant (such as an 

agricultural field that just happens to be in your image but will not be included in your canopy cover 

analysis). If your classification looks reasonable after visual inspection, proceed to the verification 

process. 
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Verifying classification accuracy 

Create another set of ROIs following the directions for the initial ROI creation. These should be 

different but done in the same manner as the classification ROIs. (For efficiency, you may want to define 

both your Classification ROIs and Verification ROIs at the same time.) Save these vector files as another 

ROI file. This is your ‘Verification ROI File’. 

You will then create a confusion matrix in ENVI classic. Open ENVI Classic, and load the classified 

image. Then ‘Restore Saved ROI file’. Go to Tools > Regions of Interest > Restore Saved ROI file. Do 

this for your initial classification ROI file and your verification ROI file. 

Now create your confusion matrix. Go to the Toolbar and select Classification > Post classification > 

Confusion Matrix Using Ground ROIs. 
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First, select the input file. Choose the classified image. Then press ‘OK’.  

You will then see a window like that in the following image. Highlight one selection from each the ‘Select 

Ground Truth ROI’ and ‘Select Classification Image’. Then select ‘Add Combination’ to match the 

ground truth to classified image. Do this until all classes are paired in the ‘Matched Classes’ window as 

shown. (This step may already be done automatically when you open the window.)  

 



 
16 

         

Once your classes are properly matched, press ‘OK’. Your confusion matrix will be created (see 

following image). Save this file where appropriate. 

 

If your confusion matrix values are acceptable, you are done with the classification process. Landis and 

Koch (1977) suggest that a Kappa coefficient > 0.8 shows strong agreement between the classified image 

and manually classified pixels. We also recommend that classification accuracy of canopy should be > 0.8 

at a minimum, and preferably 0.9 or greater.  
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Extracting zones for analysis  

This purpose of this step is simply to extract, or ‘cut out’ the piece of the image that is intended for 

analysis (e.g., the project area or stand).  

Due to well-known conflicts in the ArcGIS software, we recommend that you turn off background 

geoprocessing when following this protocol.  Open ArcMap 10.1.  Click on ‘Geoprocessing’ in the main 

toolbar and select ‘Geoprocessing options…’ from the menu. The Geoprocessing Options window will 

open.  Make sure the ‘Enable’ check box is empty under ‘Background Processing’.  Click ‘OK’ to close 

the window. 

 

Import the classified images by clicking on the add layer icon and select ‘Add data…’ and browse to the 

location where the classified image is stored (They will need to be .tif or .grid files). 
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Once you add the data, it should show up on your screen.  

To clip the classified image to the area of interest, first add a shapefile of the area of interest following 

the steps outlined above.  

(If the image is already clipped to the size needed for analysis, skip the next step.) 

Do you want to select the whole area of your shapefile as one layer for your analysis? Or, does your 

shapefile have multiple polygons that you wish to analyze separately? If you wish to select separate areas 

from one shapefile, you first need to use the selection tool to choose the polygon of interest. The 

selection tool looks like an arrow with a partially-blue square behind it on the toolbar (is highlighted by 

a blue box in the image below). Choose this tool, and then click the polygon of interest. It will be 

outlined in bright blue once selected. (See below. The selected polygon is traced in an aqua blue line. 

The un-selected polygon is black.) 
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Now that your polygon is selected, you can clip the classified raster image to this shape using the 

Extract by Mask  tool (ArcToolbox > Spatial Analyst > Extraction > Extract by Mask). Double-click the 

Extract by Mask tool to make a window appear. In the ‘Input raster’ field, browse to the raster file you 

wish to extract the data from by clicking the folder icon on the left. (Do not use the dropdown menu 

for file selection, as this often does not work correctly.) In the ‘Input raster or feature mask data’ field, 

select the shapefile to use as a mask (your polygon of interest). In the ‘Output raster’ field, browse to 

and create a new file in the desired location. (See following image.) Click ‘OK’ and wait for the process 

to complete. 

 

You will get a popup confirmation if the processes completed successfully (or if it did not). To view the 

process and results, click the “Results” tab at the bottom right of your screen. You will see all of your 

analytic processes for the session. You can re-run or modify processes by clicking on them here and 

popping up a new window. If the process failed to run, there will be error messages explaining why in 

the Results window. Consult with a GIS expert or search the internet for information about error 

messages. 
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If the process completed successfully, the clipped raster will be added to the Table of Contents and 

map. 

Now you need to export for analysis in FRAGSTATS. Left-click on the raster you wish to export, go to 

‘Data’ in the top toolbar and then ‘Export Data…’. 

 

This will open a window. Select the desired location and name for the file. In the ‘Format’ dropdown 

menu, select ‘GRID’. Then press ‘Save’. This file will now be used in FRAGSTATS. (You can also select 

‘TIFF’ files for use in FRAGSTATS.)  

You may find that you need to use ASCII files (see the ‘Analyzing spatial patterns with FRAGSTATS’ 

section of this document). To create ASCII type files, go to Arc Toolbox > Conversion Tools > From 

Raster > Raster to ASCII. Put the raster file in the ‘Input raster’ space, and select a place for the ASCII 

file to save in the second space. Press ‘OK’. 
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Analyzing spatial patterns with FRAGSTATS 

Adding files in GRID or TIFF format 

To open a GRID or TIFF file in FRAGSTATS, click the ‘Add layer…’ button in the ‘Input layers’ tab on 

the right side of the screen. In the window that opens, select ‘ESRI grid’ or ‘GeoTIFF grid (.tif)’ 

(whichever is appropriate) in the ‘Data Type Selection’ box. Then browse to the file using the ‘…’ 

button in the ‘Input a dataset of type …’ box. Click ‘OK’. Check for error messages in the bottom right 

quadrant of the FRAGSTATS screen. If there are error messages, see the ‘Workarounds for errors 

when using GRID or TIFF files’ section of this document. 

If you get an error saying that mentions ‘.dll not loaded’, the GRID file format will not work in your 

FRAGSTATS. If this is the case, you will need to use ASCII format files. For instructions about how to 

do this, see the ‘Adding files in ASCII format’ section of this document. 

You can add all layers that have the same class descriptors and run FRAGSTATS analysis at the same 

time. (See next section for information about class descriptor files.) 

Adding and creating class descriptor files 

To tell FRAGSTATS how to identify each cover category, and which category to treat as background, 

you need to add a class descriptor file. To reduce the influence of shadows on analysis, we classify them 

as part of the ‘background’.  Background pixels are ignored during FRAGSTATS calculations. 

The class descriptor file is a text file (.txt) and should be formatted as follows:  

ID, Name, Enabled, IsBackground 

1, Herb, true, false 

2, Canopy, true, false 

3, Bare_Ground, true, false 

4, Shadow, true, true 

The number in the ‘ID’ column is the number representing the category in ArcGIS, and therefore the 

ASCII, GRID or TIFF file.  Change the category names as necessary so it will accurately describe your 

file. The category you wish to treat as background (and ignore in the analysis) should have ‘true’ in the 

‘IsBackground’ column; all others should have ‘false’.  We treat the shadow category as background to 

reduce its influence.  

Once the class descriptor file is created, load it in the ‘Class descriptors’ line of the ‘Common Tables’ 

box in the bottom-left quadrant of the FRAGSTATS interface. 

Adding files in ASCII format 

If you cannot add a GRID file, you can use ASCII format files. (To create ASCII format files in ArcGIS, go 

to Toolbox > Conversion Tools > From Raster > Raster to ASCII. The file should be saved as a .txt file 

by default.) However, you must make some changes to the ASCII file to use it in FRAGSTATS. After 
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saving the file, open it in Notepad or a similar program. It will look something like this: 

 

The header rows (the first 6 rows) must be deleted from the file, but they contain information needed 

to run FRAGSTATS. Delete these rows and save the text file with a new name, making sure you 

maintain the original text file. 

Now, open the file in FRAGSTATS. Click the ‘Add layer…’ button in the ‘Input layers’ tab on the right 

side of the screen. In the box that pops up, select the ‘Raw ASCII grid’ in the Data Type Selection box. 

Then browse to the file using the ‘…’ button in the ‘Input a dataset of type Raw ASCII grid [ built-in ]’ 

box.  

After you browse to the file, an error message about the row/column number, background value, and 

cell size will appear. Close this message. Fill in the Row count, Column count, Background value, and cell 

size information using the information from the header of the original ASCII text file. For example, for 

the text file from above, you would fill in the information as shown in the following image:  
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After this is done, click ‘OK’. 

You will need to load the class descriptor files as explained earlier in this document. 

Running analysis 

 

Choosing metrics 

FRAGSTATS will compute a variety of metrics during analysis. There are patch, class and landscape 

metrics.  Patch metrics describe individual patches, class metrics describe characteristics of the 

population of patches in each category of interest, and landscape metrics describe patterns of multiple 

classes across the whole study area. Metrics including percent cover, largest patch index, edge density, 

patch size, patch density, patch perimeter-to-area ratio, and Euclidean nearest neighbor distance can be 

used to quantify the size, shape, and distribution of canopy patches across the treatment unit (Appendix 

1).  

We calculate mean, median, and standard deviation of class metrics to describe canopy within treatment 

units. We also calculate metrics for each individual patch, allowing us to graph the distribution of patch 

characteristics within analysis areas.  

To choose metrics, choose the yellow ‘Class metrics’ button near the center of the FRAGSTATS 

window. Then you choose the metrics of interest from the 5 tabs available in the ‘Class Metrics’ section. 

(See following image.) 
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In the ‘Area – Edge’ tab, check the box next to: ‘Percentage of Landscape (PLAND)’, ‘Largest Patch 

Index (LPI)”, and ‘Edge Density (ED)’. Choose ‘Patch Area’ mean, median, range, standard deviation, and 

coefficient of variation. In the ‘Shape’ tab, choose ‘Perimeter – Area Ratio (PARA_?)’ mean, median, 

range, standard deviation, and coefficient of variation. In the ‘Core area’ and ‘Contrast’ tabs, choose 

nothing. In the ‘Aggregation’ tab, choose ‘Euclidian Nearest Neighbor Distance (ENN_?)’ mean, median, 

range, standard deviation, and coefficient of variation. Also choose ‘Patch Density’ in the ‘Subdivision’ 

box.  

Repeat this process for the ‘Patch’ metrics by choosing the red ‘Patch metrics’ button and then selecting 

metrics of interest from the various tabs. You might consider calculating Patch Area (on the ‘Area – 

Edge’ tab) and Perimeter to Area Ratio (on the ‘Shape’ tab).  

Setting up analysis parameters 

Before running analysis you need to make sure the correct types of metrics will be run, and that the 

results will be saved appropriately.  Go to the ‘Analysis Parameters’ tab in the top right corner. Choose 

the ‘8 neighbor rule’. (Under the 8-neighbor rule pixels adjacent vertically, horizontally and on the 

diagonal are classified as neighbors.  This is a more accurate representation of the real-world adjacency 

of cover classes than the alternative 4-neighbor rule, which only defines pixels adjacent directly vertically 

and horizontally as neighbors.) It is also useful to set the program so it will automatically save results. 

Check the box next to this and browse to the location where you’d like the file to be saved. Finally, 
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choose the metric types you wish to calculate. For our purposes, only check the ‘Patch metrics’ and 

‘Class metrics’ boxes. The ‘Analysis parameters’ tab should look like the following picture:

 

 

You are now ready to run the analysis. 

Running FRAGSTATS analysis 

Click the ‘Run’ button at the top of the page. After pressing ‘Proceed’ on the dialog box, the analysis 

should run. The analysis may take a few minutes, depending on how many metrics were selected and 

size of files. (See image below for visual of processing screen.)  

(Analysis should not complete instantly. If it does, look at the Activity log for error messages. If you 

receive error messages, see notes later in this document on ‘Workarounds for errors when using 

.GRID or .TIFF files’.) 
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After the processing is complete, look at the results. To do this, select the ‘Results’ button in the center 

of the screen (You may need to scroll down to see this option).  

The results for selected metrics will show in the appropriate tab. The results will show in tabs of the far 

right panel. We were only interested in the ‘Canopy’ class metrics for our analysis, though you may be 

interested in metrics for other cover categories (such as herbaceous cover). The results shown will be 

for the file highlighted in the ‘Run list’ in middle panel (see following image). All results will be saved in 

text files located where you chose in the ‘Automatically save results’ option of the ‘Analysis parameters’ 

tab on the left.  
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Workarounds for errors when using GRID or TIFF files 

If you encounter an error when trying to process a .GRID file that says ‘[Grid IO error encountered 

while loading: C:\PATH_TO_FILE]. Model execution halted’ or when trying to load a .TIF file that says 

‘Error: FRAGSTATS cannot process landscapes with non-square cells’ there is a rounding problem in 

your input data causing the cells to be slightly non-square. (See the explanation in the answer to Q12 on 

the FRAGSTATS FAQ page: www.umass.edu/landeco/research/FRAGSTATS/faq/FRAGSTATS_faq.html.) 

You need to re-save the file so that the cells are exactly square. To do this, convert the file to ASCII and 

then re-convert it back to a .GRID file. To convert to ASCII, go to the Toolbox > Conversion Tools > 

From Raster > Raster to ASCII. (See the following image.) 
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You will then go to Toolbox > Conversion Tools > To Raster > ASCII to Raster. Convert the ASCII file 

you just created to a raster. Save the output data type as ‘INTEGER’. This new raster should work in 

FRAGSTATS. (See the following image.) 
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An additional non-FRAGSTATS metric: Euclidean Nearest Random 

Point Distance 

The Euclidean distance between randomly generated points and the nearest contiguous tract of canopy 

(Euclidean Nearest Random Point Distance, ENRP) may be calculated to quantify the prevalence and size 

of gaps (Table 1), in addition to calculating the FRAGSTATS metrics discussed earlier.  This is similar to 

the Euclidean Nearest Neighbor Distance (ENN) metric generated in FRAGSTATS.  However, the 

random points used to quantify the ENRP can fall anywhere within the treatment unit, including non-

canopy gaps.  The prevalence and size of non-canopy openings are quantified by measuring the distances 

between the random points and the nearest canopy gaps. This metric is not calculated by FRAGSTATS 

and must be calculated in ArcMap.  

 

Table 1. An additional non-FRAGSTATS metric. 

Metric Definition, interpretation and 

units 

 

Expected trend for canopy 

cover metrics with increased 

spatial heterogeneity 

 

Euclidian Nearest Random Point 

Distance (ENRP) 

The shortest straight-line distance 

(m) between a random point and the 

nearest contiguous tract of canopy is 

a simple indicator of the prevalence 

and size of canopy gaps. Mean, range 

and standard deviation reported. 

Frequency distribution graphs may 

also be plotted. 

Increase in mean distance, range, and 

standard deviation. 

 

Calculating the Euclidean Nearest Random Point Distance metric 

To calculate the Euclidean Nearest Random Point Distance (ENRP) metric open the boundary shapefile 

for the polygon of interest and the extracted classified image for your area of interest in ArcMap. 

Next, generate 1000 random points within the area of interest (most likely, the treated stand[s]).  To do 

this use the Create Random Points tool (ArcToolbox > Data Management > Feature Class > Create 

Random Points).  Double-click the Create Random Points tool to make a window appear. Specify a 

directory for the new shapefile in the ‘Output Location’ field and a name for the shapefile in the ‘Output 

Point Feature Class’ field. Specify the boundary shapefile as the ‘Constraining Feature Class’.  Select 

“Long” under the ‘Number of Points’ and enter “1000” in the box.  Leave the ‘Minimum Allowed 

Distance’ field blank (see following image).  Click ‘OK’ and wait for the process to complete.  If the 

process completes successfully, the random points shapefile will be added to the Table of Contents and 

map. 
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Once the points have been generated, calculate the distances between each random point and its 

nearest canopy patch.  To do this, convert the classified image from a raster to a point shapefile and 

extract only those points representing raster cells covered by canopy.  Then, calculate the distance from 

the random points to the nearest canopy cover point. 

 

Use the ‘Raster to Point’ tool (ArcToolbox > Conversion Tools > From Raster > Raster to Point) to 

convert the raster to a point shapefile.  Double-click the ‘Raster to Point’ tool to make a window 

appear. Specify the extracted classified image for the area of interest as the ‘Input raster’, and “VALUE” 

as the ‘Field’.  Specify an output directory and file name in ‘Output point features’. Click ‘OK’ and wait 

for the process to complete (see following image).  If the process completes successfully, the classified 

image point shapefile will be added to the Table of Contents and map. 
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Next, select only those points representing raster cells covered by canopy by using the ‘Select By 

Attributes’ tool.  Click on the ‘Selection’ menu on the top toolbar and, within this menu, choose ‘Select 

By Attributes…’.  The Select By Attributes window should open.  Specify the classified image point layer 

in the ‘Layer’ dropdown menu. Select ‘Create a new selection’ as the method.  In the third box, select 

“GRID_CODE”, then hit the ‘=’ button. Hit the ‘Get Unique Values’ button and select the value 

representing the canopy cover in the box on the left-hand side.  The bottom box should show the 

following (Where n is the value representing the cells covered by canopy):  “GRID_CODE” = n.  Click 

‘OK’ and wait for the process to complete. The canopy cover points should now be selected.  To 

export these points to a new shapefile, right click on the classified image point layer in the Table of 

Contents and select Data > ‘Export Data…’.  Export the selected features only, and specify an output 

directory and file name (select “Shapefile” in the ‘Save as type:’ dropdown menu). Click ‘OK’.  If the 

process completes successfully, the classified image point shapefile will be added to the Table of 

Contents and map.   
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Finally, calculate the distance from the random points to the nearest canopy cover point using the Near 

tool (ArcToolbox > Analysis Tools > Proximity > Near). Double-click the Near tool to make a window 

appear. Enter the random points shapefile in the ‘Input Features’ field and the canopy points in the ‘Near 

Features’ field.  Leave the ‘Search Radius’ field blank.  Click ‘OK’ and wait for the process to complete.  

The Near tool will add two fields to the attribute table of the random points shapefile.  The 

“NEAR_FID” field contains the feature identification number of the nearest canopy point.  The 

“NEAR_DIST” field contains the distance to the nearest canopy point (the units correspond to the 

random points shapefile’s coordinate system).  
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Now, calculate the mean, range and standard deviation of these distances.  Open the attribute table by 

right clicking on the random points shapefile in the table of contents and select ‘Open Attribute Table’.  

In the attribute table, right click on ‘NEAR_DIST’, and select ‘Statistics’.  A new window showing the 

summary statistics and a frequency histogram for the distances field will appear.  Make sure 

‘NEAR_DIST’ is selected under ‘Field’.  The summary statistics calculated include: count, minimum, 

maximum, sum, mean, standard deviation and number of nulls.  The range can be calculated by 

subtracting the minimum value from the maximum value.  
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Example: Application of methods to a test area of the Front 

Range landscape 
We present results of a test run using an area of forest on Colorado’s Front Range that was used to 

develop this protocol.  We used two small sub-areas to compare an area with a fragmented forest 

canopy (Area 1) with a more contiguously forested area (Area 2). 

Figure 1. Aerial image (a) and classification of image into cover classes (b) for low-density forest Area 1. Classes include 

coniferous canopy (green), bare soil (yellow), herbaceous cover (red) and shadow (blue). For analysis, herbaceous and bare soil 

were combined into the canopy gap class and shadows were classified as background. 

a) Raw NAIP aerial photography                                                                    b) Classified image  

  
 

Figure 2. Aerial image (a) and classification of image into cover classes for high-density forest Area 2. Classes include 

coniferous canopy (green), bare soil (yellow), herbaceous cover (red) and shadow (blue). For analysis, herbaceous and bare soil 

were combined into the canopy gap class and shadows were classified as background. 

a) Raw NAIP aerial photography                                                                      b) Classified image  

              

 

Accuracy of the image classification 
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The accuracy of the supervised image classification was tested against an independent dataset of 

manually classified pixels. The overall accuracy of the classification was 87.1% with a Kappa statistic of 

0.82. Landis and Koch (1977) suggest that Kappa statistics > 0.8 show strong agreement between the 

classified image and manually classified pixels.  The confusion matrix (Table 2) shows that 86.67% of the 

coniferous pixels were correctly identified. 

Table 2: Confusion matrix of classified image resampled to a 2.4 m resolution using independent dataset of 

manually classified pixels. 

  Ground Truth (%) 
  Herbaceous Conifer Shadow Bare 

Ground 
Total   

C
la

s
s
if

ic
a
ti

o
n
 

Herbaceous 82.57 10.08 2.77 8.16 36.25   
Conifer 5.85 86.67 3.78 0.00 26.32   
Shadow 0.00 3.25 93.45 0.00 17.18   
Bare Ground 11.58 0.00 0.00 91.84 20.25   
Total 100.00 100.00 100.00 100.00 100.00   

 

Basic interpretation of FRAGSTATS results  

Area 1 has a smaller percentage of openings (43%) than canopy coverage (57%), but a similar density of 

openings and canopy clumps (Table 3).  In contrast, Area 2 has a greater percentage opening than Area 

1 (66%) and less coverage of canopy (34%) with a higher density of openings (1843 per hectare) than 

canopy clumps (837 per hectare).  The largest patch index (LPI) shows that 44% of Area 1 was occupied 

by a single opening; in comparison, 36% of Area 2 was occupied by a single canopy clump.  The edge 

density of Area 1 (1113 m per hectare) was higher than Area 2 (805 m per hectare), suggesting that 

Area 1 is more fragmented with a greater influence of edge effects on the ecological processes within 

the canopy clumps and open gaps (e.g., shading of canopy over open gaps). 

Within Area 1, the canopy clumps and openings had similar mean patch sizes with high variation (mean 

and standard deviation of 0.04 ha ± 0.28 and 0.05 ha ± 0.59 respectively; Table 3).  In comparison, within 

Area 2, the canopy clumps were much larger than the openings on average (mean of 0.08 ha and 0.02 ha 

respectively).   The perimeter area ratios were similar in both areas, suggesting that in both areas the 

edges of openings and canopy clumps were convoluted and complex.  

Euclidean nearest neighbor distance is a measure of patch proximity.  It was consistent in both areas, at 

approximately 6 m.  However, the standard deviation of distance between openings was larger in Area 2 

than Area 1. The frequency distribution plots of the Euclidean nearest neighbor distance for canopy 

clumps and open gaps vary between Area 1 and Area 2 (Figure 3; please note that the scales on the axes 

differ between the plots).  The maximum distance between open gaps was greater in Area 2 (> 50 m) 

than Area 1 (~ 20 m).      

Overall, these metrics indicate Area 1 is more open with greater fragmentation of the canopy and a 

greater variety in the distances between and sizes of canopy clumps.  We suggest that area 1 is closer to 

the desired future conditions that the FR-CFLRP is aiming to create within treatment units. 
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Table 3: Metrics measuring forest canopy cover spatial structures for areas 1 and 2. 

 

 

 

  

Metric and units Area 1  Area 2 

% of Landscape 42.52  65.95 

Patch density (ha-1) 1079  837 

Largest patch index (%) 15.49  36.56 

Edge density (m ha-1) 1113  805 

Patch area (ha) Mean 0.0394  0.0788 

Range 3.3420  12.3800 

Std. dev. 0.2789  0.9665 

Perimeter to area ratio Mean 11616  12796 

Range 13243  13052 

Std. dev. 4476  4056 

Euclidian nearest 

neighbor distance (m) 

Mean 6.40  6.0 

Range 20.26  15.6 

Std. dev. 3.13   2.5 
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Figure 3. Frequency distribution histograms of the Euclidean distance to the nearest neighbor for canopy clumps 

(a) and openings (b) in Area 1 and 2. Distance in meters is on x-axis and frequency on y-axis.  
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Conclusions 
The monitoring method described here allows comparison of the horizontal distribution of canopy 

cover among treatment units and through time.  These methods can quantify forest spatial structure 

before treatment and then can be repeated each time the NAIP or forest resource imagery is taken 

(approximately every 3 years). 

These methods provide quantitative tools to help define desired future conditions for forest spatial 

structure. These metrics are reasonably intuitive to understand (e.g. patch mean size and distance 

between patches) and can provide a common language for discussing difficult-to-explain spatial patterns 

of forest characteristics. 

Inherent limitations of aerial photography will restrict the use of and inference we can draw from these 

methods. The 2.4 m resolution mitigates problems caused by small within-canopy shadowing; however, 

the problem of occasional large, deep shadows due to steep topography cannot be completely resolved.  

Furthermore, the use of aerial imagery can only provide information in the horizontal distribution of 

canopy but not the vertical forest structure. Field-collected common stand exam plot techniques will 

provide data on the means and ranges of tree sizes and densities within treatment units. 
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Appendix I. Details about FRAGSTATS metrics 

 
Table A.1. Information about selected FRAGSTATS metrics. 

Metric Definition, interpretation and units 

Expected trend for canopy cover 

metrics with increased spatial 

heterogeneity 

Percentage of 

Landscape (PLAND)  

Area of each patch type as a percent of total 

landscape area (%). 

Decrease  

  

Largest Patch Index 

(LPI)  

The percentage of total landscape area 

comprised by the largest patch (%).  It is a 

measure of the dominance of the largest patch of 

each patch type. 

Decrease 

Edge Density (ED) The length of patch edge per unit area (m/ha) for 

each patch type. Edges are where adjacent 

patches influence each other are an important 

driver of ecological processes in complex 

landscapes.  

Increase 

Patch Area (PA) The size of a patch by type (ha). Mean, range, 

standard deviation reported. Frequency 

distribution graphs of patch area may also be 

plotted using patch-level metrics. 

Decrease in mean with increase in range 

and standard deviation  

Perimeter Area Ratio 

(PARA) 

A ratio of the perimeter of a patch to its area 

(unitless).  Large perimeter-to-area ratios 

indicate convoluted or complex edges with 

greater proportions of the area influenced by 

neighboring patches. Mean, range, and standard 

deviation reported. Frequency distribution 

graphs may also be plotted using patch-level 

metrics. 

Increase as stand becomes more 

fragmented and/or patches become 

more irregular 

Patch Density (PD) Simple measure of the density of patches per 

100 hectares. Patch density is an indication of 

the prevalence of patch types (i.e. canopy or 

opening) and is strongly influenced by the size of 

patches. 

Increase  

Euclidean Nearest 

Neighbor Distance 

(ENN) 

The shortest straight-line distance between the 

focal patch (m) and its nearest neighbor of the 

same type. This simple measure of patch context 

is used to quantify patch isolation. Mean, range 

and standard deviation reported.   Frequency 

distribution graphs may also be plotted using 

patch-level metrics. 

Increase in mean with increase in range 

and standard deviation  
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The list below shows formulae for selected FRAGSTATS metrics. For more information about the full 

range of metrics available, see the FRAGSTATS website at www.umass.edu/landeco/research/fragstats/ 

fragstats.html. 

 

Percent of Landscape (PLAND) 

 

 

Patch Density (PD) 

 

 

Largest Patch Index (LPI) 

 

 

Edge Density (ED) 

 

 

Patch Area (PA) 
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Perimeter to Area Ratio (PARA) 

 

 

Euclidian Nearest Neighbor Distance (ENN) 
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Appendix II. Useful GIS skills 
 

Creating shapefiles with new features 

First, you need a shapefile to edit. One easy way to create a new shapefile is to export an existing 

shapefile as a new one. To do this, left click on the layer, go to ‘Data’, and then click ‘Export data…’ 

(See following image.) Save the layer with a new name in a location that works for you.  

 

To create or change attributes in layers, you need to start an editing session. In your toolbar, you 

should see a menu titled ‘Editor’. Choose ‘Start Editing…’ (See following image.) 
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If you do not see the Editor toolbar, you can get it by going to Customize > Toolbars… and then 

checking next to ‘Editor’. 
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After you click ‘Start Editing’, a window will pop up. Choose the file you wish to edit. Press ‘OK’.  

A panel of your screen will now say ‘Create Features’. You will be editing features in all of the files that 

show up in this window. (In 2nd screenshot that follows, both the BobcatFirePerim and NewShapefile 

were open to editing. You will usually only want to edit one file, so be careful.) Then click the 

construction tool you wish to use. For polygons, use the polygon tool. Trace an area you want to 

digitize with your points. If no construction tools are shown, you will need to click the icon in the top 

right corner of the Create Features window and click ‘Show all templates’.  

 

To delete attributes, open the attribute table by left-clicking on the file you are editing. (See following 

image.) 
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You can then delete attributes from this file by clicking on the row and pressing ‘Delete’.  

When you want to save your edits, press ‘Save Edits’ in the editor toolbar dropdown menu. When you 

are done editing, click ‘Stop Editing’ in the Editor toolbar. 

To add NAIP Imagery via ArcGIS Server 

Open the Catalog in GIS. You can open it by going from Windows > Catalog. Or, you can click the icon 

that looks like this:  

 

Then open the GIS Severs folder, and click the ‘Add ArcGIS Server’ line. A window will pop up. Click 

‘Next’.  Paste this URL (http://gis.apfo.usda.gov/arcgis/services) into space next to the Internet 

button. Click ‘Finish’. 

A server titled ‘arcgis on gis.apfo.usda.gov’ will now be shown. Open this server and browse to 

the data of your choice. Drag the data to the Table of Contents to display it on the map. 

  

http://gis.apfo.usda.gov/arcgis/services
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Appendix III. Related links and documents 
 

ArcGIS website: http://www.esri.com/software/arcgis 

ENVI software website: http://www.exelisvis.com/ProductsServices/ENVI/ENVI.aspx 

ENVI tutorials: http://www.exelisvis.com/Learn/Resources/Tutorials.aspx 

Front Range Roundtable Collaborative Forest Landscape Restoration Program website: 

http://frontrangeroundtable.org/CFLRP.php 

FRAGSTATS website: http://www.umass.edu/landeco/research/fragstats/fragstats.html 

FRAGSTATS documentation, including detailed description of metrics: 

http://www.umass.edu/landeco/research/fragstats/documents/fragstats.help.4.2.pdf 

National Agricultural Inventory Program (NAIP) imagery information: 

http://www.fsa.usda.gov/FSA/apfoapp?area=home&subject=prog&topic=naip 

National Collaborative Forest Landscape Restoration Program (CFLRP) information: 

http://www.fs.fed.us/restoration/CFLRP/  
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